Edgewall Software

Opened 8 years ago

Closed 8 years ago

#583 closed defect (duplicate)

Exception: Unhandled node type <class '_ast.NameConstant'>

Reported by: jaraco@… Owned by: cmlenz
Priority: major Milestone: 0.7
Component: General Version: 0.6
Keywords: Cc:

Description

This simple script:

template = """<?xml version="1.0" encoding="utf-8" standalone="yes"?>
<body xmlns:py="http://genshi.edgewall.org/" py:strip="True">
</body>
"""

import genshi.template.markup

tmpl = genshi.template.markup.MarkupTemplate(template)
tmpl.generate()

Will produce the Exception "Unhandled node type <class '_ast.NameConstant?'>" in genshi.template.astutil:90 on Python 3.4 (and possibly other Python 3 variants).

Change History (1)

comment:1 Changed 8 years ago by jaraco@…

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #582

Note: See TracTickets for help on using tickets.