Edgewall Software

Opened 3 years ago

Closed 2 years ago

Last modified 21 months ago

#565 closed defect (fixed)

[PATCH] assert statement with sideeffect

Reported by: peinthor@… Owned by: cmlenz
Priority: major Milestone: 0.7
Component: Template processing Version: 0.6
Keywords: Cc:



There is a nasty assert statement in markup.py with a sideeffect. And if for example you have an optimized genshi installation it breaks, because the assert call gets removed.

Patch is attached that should fix this.

Attachments (1)

genshi_assertsideffect.diff (610 bytes) - added by anonymous 3 years ago.
patch for assert fix

Download all attachments as: .zip

Change History (6)

Changed 3 years ago by anonymous

patch for assert fix

comment:1 Changed 3 years ago by rblank

Wow, good catch. I wonder if this could be the cause of template include failures in Trac that some users have been experiencing, like #7463.

comment:2 Changed 3 years ago by peinthor@…

yes this breaks the xi:fallback it will just render until the first fallback statement and then completely stop.

comment:3 Changed 2 years ago by hodgestar

  • Resolution set to fixed
  • Status changed from new to closed

Thanks for the bug report and patch! Applied in r1239 and backported to 0.6.x and 0.7.x in r1240 and r1241 respectively.

comment:4 Changed 2 years ago by warner

This bug just bit me (in trac), in Genshi-0.6.1 (the latest genshi that's selected by the latest stable trac-0.12.5, which says "Genshi<=0.6,<0.7dev"). I don't think the fix is in Genshi-0.7.0 either.

Has there been a 0.6.x or 0.7.x release that includes this fix?

-Brian Warner, tahoe-lafs.org

comment:5 Changed 21 months ago by hodgestar

Not yet, but there should be one soon.

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
as closed The owner will remain cmlenz.
The resolution will be deleted. Next status will be 'reopened'.

E-mail address and user name can be saved in the Preferences.

Note: See TracTickets for help on using tickets.