Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

#341 closed defect (duplicate)

Transformer.filter omitting end tags

Reported by: bobbysmith007@… Owned by: cmlenz
Priority: major Milestone: 0.6
Component: Template processing Version: 0.5.1
Keywords: Cc:

Description

This bug was reported and diagnosed on http://trac-hacks.org/ticket/5997

  • Applying a Transformer('div[@id="content"]/h1/text()').filter to was causing some end/begin tags of the tags in/around it to disappear (as described on the above ticket)
  • The above ticket relates to a stream filter on the template /trac/ticket/templates/report_view.html
  • http://trac-hacks.org/changeset/6790 Describes how I fixed the bug (by using Dave Abrahams implementation of filter (as provided to me in a patch long ago)).

Sorry if this is not a bug, I am not familiar enough with Genshi to tell if I am just using it incorrectly. If so, please suggest an alternative solution.

If you need any further information please don't hesitate to ask.


System Info:

Trac:		0.11.6stable-r8458
Python:		2.6.2 (release26-maint, Apr 19 2009, 02:15:38) [GCC 4.3.3]
setuptools:	0.6c9
psycopg2:	2.0.8
Genshi:		0.5.1
mod_python:	3.3.1
GIT:		1.6.0.4
jQuery:		1.2.6

Attachments (0)

Change History (2)

comment:1 Changed 6 years ago by bobbysmith007@…

Hold off on this, I believe with a fresher genshi/branches/stable/0.5.x that this works fine.

I will report back when I have more data

comment:2 Changed 6 years ago by bobbysmith007@…

  • Component changed from General to Template processing
  • Resolution set to duplicate
  • Status changed from new to closed

This was seems to have been fixed in genshi #290 [1000]

Sorry for the dup, didnt find it when I searched

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain cmlenz.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.