Edgewall Software

Ticket #201 (closed defect: duplicate)

Opened 7 years ago

Last modified 7 years ago

AttributeError: 'NoneType' object has no attribute 'changeset'

Reported by: anonymous Owned by: cmlenz
Priority: major Milestone:
Component: Infrastructure Version:
Keywords: Cc:

Description

How to Reproduce

While doing a GET operation on /build, Trac issued an internal error.

(please provide additional details here)

System Information

Trac 0.11dev-r6683
Python 2.4.3 (#2, Oct 6 2006, 07:49:22)
[GCC 4.0.3 (Ubuntu 4.0.3-1ubuntu5)]
setuptools 0.6c7
psycopg2 2.0.5.1
Genshi 0.5dev-r801
Pygments 0.9
Subversion 1.3.2 (r19776)

Python Traceback

Traceback (most recent call last):
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/web/main.py", line 419, in _dispatch_request
    dispatcher.dispatch(req)
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/web/main.py", line 196, in dispatch
    resp = chosen_handler.process_request(req)
  File "/usr/lib/python2.4/site-packages/Bitten-0.6dev_r497-py2.4.egg/bitten/web_ui.py", line 128, in process_request
    self._render_overview(req)
  File "/usr/lib/python2.4/site-packages/Bitten-0.6dev_r497-py2.4.egg/bitten/web_ui.py", line 166, in _render_overview
    req.hdf[prefix + '.youngest_rev'] = {
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/wiki/formatter.py", line 1123, in wiki_to_oneliner
    OneLinerFormatter(env, context).format(wikitext, out, shorten)
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/wiki/formatter.py", line 950, in format
    result = re.sub(self.wikiparser.rules, self.replace, result)
  File "/usr/lib/python2.4/sre.py", line 142, in sub
    return _compile(pattern, 0).sub(repl, string, count)
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/wiki/formatter.py", line 804, in replace
    replacement = self.handle_match(fullmatch)
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/wiki/formatter.py", line 797, in handle_match
    return external_handler(self, match, fullmatch)
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/versioncontrol/web_ui/changeset.py", line 875, in <lambda>
    y, z))
  File "/usr/local/virtualenv/lib/python2.4/site-packages/Trac-0.11dev_r6683-py2.4.egg/trac/versioncontrol/web_ui/changeset.py", line 897, in _format_changeset_link
    href=(formatter.href.changeset(rev, path) +
AttributeError: 'NoneType' object has no attribute 'changeset'

Attachments

Change History

Changed 7 years ago by cmlenz

  • status changed from new to closed
  • component changed from General to Infrastructure
  • version 0.4.4 deleted
  • resolution set to duplicate
  • milestone 0.5 deleted

Dupe of #195.

Add/Change #201 (AttributeError: 'NoneType' object has no attribute 'changeset')

Author


E-mail address and user name can be saved in the Preferences.


Change Properties
<Author field>
Action
as closed
The resolution will be deleted. Next status will be 'reopened'
 
Note: See TracTickets for help on using tickets.