Edgewall Software
Modify

Opened 10 years ago

Closed 10 years ago

Last modified 4 years ago

#80 closed defect (fixed)

<xi:fallback> content always shown

Reported by: cboos Owned by: cmlenz
Priority: major Milestone: 0.4
Component: Template processing Version: devel
Keywords: xi:include xi:fallback Cc:

Description

With latest trunk (r462), I've noticed that the <xi:fallback> content is always shown, regardless of whether the <xi:include> target was found or not.

This is visible e.g. in Trac's report template.

Attachments (3)

unit_test_xi_fallback-r462.diff (1.8 KB) - added by cboos 10 years ago.
Unit-test demonstrating the issue
fix_xi_fallback-r462.diff (1.4 KB) - added by cboos 10 years ago.
Potential fix for the issue
fix_xi_fallback-r462.2.diff (1.3 KB) - added by cboos 10 years ago.
Simplified a bit the previous fix

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by cboos

Unit-test demonstrating the issue

Changed 10 years ago by cboos

Potential fix for the issue

comment:1 Changed 10 years ago by cboos

With attachment:fix_xi_fallback-r462.diff, the problem is solved, i.e. the first unit test added in attachment:unit_test_xi_fallback-r462.diff now succeeds and my original issue with Trac's Report template is also fixed. All the other unit-tests still pass.

Changed 10 years ago by cboos

Simplified a bit the previous fix

comment:2 Changed 10 years ago by cboos

  • Version changed from 0.3.3 to devel

comment:3 Changed 10 years ago by cmlenz

  • Status changed from new to assigned

Thanks for the patches!

comment:4 Changed 10 years ago by cmlenz

  • Resolution set to fixed
  • Status changed from assigned to closed

Should be fixed in [463]. I expanded your patch a bit so that we can now support nested fallback content.

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain cmlenz.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.