Edgewall Software
Modify

Opened 6 years ago

Closed 6 years ago

#319 closed defect (wontfix)

genshi 0.6 and agilo 0.7.4.1

Reported by: cerbere99@… Owned by: cmlenz
Priority: major Milestone:
Component: General Version: 0.5.1
Keywords: Cc:

Description

i am trying to run agilo on trac 0.11 but it is complaining about version conflict with genshi 0.6 if i downgrade to 0.5.1 for genshi it will break trac and give me a 500 error any suggestions? the error message is:

ERROR: Skipping "agilo.charts.macros = agilo.charts.macros": (version conflict "VersionConflict?: (Genshi 0.6dev-r1063 (/usr/lib/python2.4/site-packages/Genshi-0.6dev_r1063-py2.4-linux-i686.egg), Requirement.parse('genshi>=0.5.1,<0.6dev'))") Tags: is there any plan to make genshi compatible with that kind of plugins?

Attachments (0)

Change History (1)

comment:1 Changed 6 years ago by cboos

  • Milestone 0.6 deleted
  • Resolution set to wontfix
  • Status changed from new to closed

on trac 0.11 but it is complaining about version conflict with genshi 0.6 if i downgrade to 0.5.1 for genshi it will break trac

No, Trac 0.11.x (even with AgiloForScrum) works fine with 0.5.1 (see e.g. Trac:TracDev/ReleaseTesting), so downgrading shouldn't have been a problem and you would have met the constraints imposed by agilo.charts.macros.

There was something wrong with the installation (see Trac:InstallationIssue).

Add Comment

Modify Ticket

Change Properties
Set your email in Preferences
Action
as closed The owner will remain cmlenz.
The resolution will be deleted. Next status will be 'reopened'.
Author


E-mail address and user name can be saved in the Preferences.

 
Note: See TracTickets for help on using tickets.